Spectrum and Odyssey 1 - Not Working

What emulators do you like best? Know any tips to make them run even smoother? Share your thoughts about emulators here!
Post Reply
scottbright
Member
Member
Posts: 1
Joined: Tue Nov 21, 2017 1:50 pm

Spectrum and Odyssey 1 - Not Working

Post by scottbright » Fri Oct 12, 2018 4:48 pm

I've got most emulators working except Odyssey 1 and ZX Spectrum.

- Spectrum: won't load any roms and the Start Spectrum doesn't do anything. Get the Initializing window them back to the front end.

- Odyssey 1: The CARTS are just text files. I think that's correct, but again nothing loads.

Anyone get these working?
These are both using MAME correct? I don't see separate emulators for them.
-------------------------------------------------------
ok, found a different set of roms for spectrum. I can only get the .rom format to work.
Last edited by WheatPasta on Thu Oct 18, 2018 6:44 pm, edited 1 time in total.
Reason: Merged double post

User avatar
WheatPasta
Moderator
Moderator
Posts: 846
Joined: Sat Oct 28, 2017 2:21 am

Re: Spectrum and Odyssey 1 - Not Working

Post by WheatPasta » Thu Oct 18, 2018 6:56 pm

scottbright wrote:
Fri Oct 12, 2018 4:48 pm
Anyone get these working?
While I have not tried the Spectrum or Odyssey 1 like you mention the stock front end should be using MAME to run these, and MAME looks for roms to be written and compressed a certain way. This is the way it is with Coleco at least. ZX81 should be in the Retro Reload if I remember right, but i am not sure about the Odyssey.
If you are having a software problem be it front end, Windows, or want to try RetroArch and LauchBox but need help feel free to contact me. Post on the forum, PM here, or on Discord. I will be more then happy to do my best to get you sorted.

Post Reply