Replay Blue Light Turn On, But Nothing Else

If you have hardware related issues with your Replay unit then look here for answers. If you can't find your answer, then make a post and someone will help you out.
Post Reply
braveheart
Member
Member
Posts: 1
Joined: Thu Jan 25, 2018 3:12 am

Replay Blue Light Turn On, But Nothing Else

Post by braveheart » Mon Apr 29, 2019 11:10 pm

Hello,

I have used my Replay in the past, but haven't for a couple of months. Today when I tried to turn it on the blue lights came on and so did the light on the USB adapter I have for my controllers, but nothing else happened. I don't hear the normal booting up sounds or the fan spinning and there is nothing on the screen. I unplugged cables and plugged them back in, powered the device on and off multiple times and have also plugged it into a monitor with VGA. Still nothing.

Any suggestions on what I can try to get this working? It was fun while it worked. It has literally been sitting in the same spot next to my TV for months and hasn't had any issues until now.

Thanks,
Don

Jrudolph17
Member
Member
Posts: 1
Joined: Sat Aug 11, 2018 3:39 pm

Re: Replay Blue Light Turn On, But Nothing Else

Post by Jrudolph17 » Sun May 12, 2019 7:02 pm

Same issue.

Landshark
Member
Member
Posts: 8
Joined: Thu Jan 25, 2018 5:19 am

Re: Replay Blue Light Turn On, But Nothing Else

Post by Landshark » Mon Jun 03, 2019 7:53 pm

I came back to see if I got any update from Steve in to my comment about the same issue. It's been a month and nothing. Maybe this is why it's only a 6 month warranty. It's a real shame how much tinkering this thing took and region issues on Genesis and n64 sound issues. Not only did it have a negative effect on my wallet, it ate up my gaming time for troubleshooting. Hopefully they will help those of us out with this same issue when their next shipment arrives. I can't remember the last time I had an electronic die while it was put away...

User avatar
Mireille2015
Moderator
Moderator
Posts: 817
Joined: Mon Nov 20, 2017 7:50 pm
Location: USA TEXAS
Contact:

Re: Replay Blue Light Turn On, But Nothing Else

Post by Mireille2015 » Mon Jun 03, 2019 10:15 pm

I do apologize for those who are experiencing this. WheatPasta and I are finding ways to help folks like this behind scenes. But, it's very hard to troubleshoot these symptoms without physically having the hardware itself. It could be a bad VGA/HDMI port. Corrupted drive. Problem with the PCB itself.

The region for Genesis is due to MAME. The N64 is typical due to numerous plugins out there.

WheatPasta and myself are working together on showing folks how easily it is to switch all emulation to Retroarch, and keep everything else stock.
"There is no Replay! Only Zuul!"

Landshark
Member
Member
Posts: 8
Joined: Thu Jan 25, 2018 5:19 am

Re: Replay Blue Light Turn On, But Nothing Else

Post by Landshark » Thu Jun 13, 2019 10:49 pm

I appreciated all the help guys, wheatpasta helped me with my n64 problems. It will just be nice to know if we are sol or if we get something back to make us less upset. I've been enjoying retroarch on my 3ds and real retro collecting in the meantime.

Post Reply